Aus RN-Wissen.de
Wechseln zu: Navigation, Suche


Schaltungen simulieren mit LTSpice/SwitcherCAD am Beispiel von SwitcherCAD III


Was ist LTSpice/SwitcherCAD?

SwitcherCad ist eine Software um Schaltungen am PC zu simulieren. Die Software ist kostenlos über die Website von Linear Technologies (siehe Weblinks) zu bekommen und wird auch von dieser Firma produziert und weiterentwickelt.

Das Programm basiert auf dem älteren Simulationsprogramm Spice, und ist vor allem um die graphische Oberfläche erweitert. Damit kann die Schaltung graphisch als Schaltplan eingegeben werden, und auch die Ergebnisse (Spannungen, Frequenzgänge und anderes) können als Kurven angezeigt werden. Das Programm ist sehr mächtig und bietet viel Möglichkeiten, so dass hier nur eine erste Einführung gegeben werden kann.

Als ein einfacher Fall für den Anfang, können Spannungen und Ströme in der Schaltung als Funktion der Zeit angezeigt werden. Bei einer realen Schaltung entspricht dies einer Messung mit Funktionsgenerator und einem Oszilloskop, ohne die Grenzen eines realen Oszilloskops. Möglich sind aber auch Simulationen als Funktion der Frequenz(Sinus), Temperatur oder eines anderen Parameters und eine Simulation von Rauschen.

So kann man eine Schaltung ausprobieren, analysieren und Parameter variieren, ohne die Bauteile und Messgeräte zu kaufen, und die Schaltung aufbauen zu müssen. Das spart natürlich Zeit und Geld, das wichtigste ist aber wohl, dass man so Fehler entdecken kann bevor man anfängt die Schaltung zu realisieren. Auch kann man Fehler meist leichter finden, weil Fehler wie kalte Lötstellen entfallen, und man auch kleinste Ströme und Spannungen ohne Rückwirkung darstellen kann.

Gerade im Roboterbau mit Hobbymitteln ist das von großem Vorteil, da die Geldmittel und Messgeräte begrenzt sind und man sich viele Dinge selbst bauen muss.

Wo bekommt man das Programm?

Die Software steht zum Download frei zur Verfügung (siehe Weblinks). Etliche Modelle von Bauteilen sind schon beinhaltet, aber es gibt auch noch zusätzliche Modelle zum downloaden. Natürlich sind die Modelle von Bauteilen der Herstellerfirma in der Überzahl. Für Modelle anderer Hersteller sollte man auf deren Websites schauen.

Nach dem Download muss die Software selbstverständlich installiert werden. Die Installation ist aber sehr einfach und bedarf eigentlich keiner Erklärung.


Der erste Schaltplan

Als allererste Simulation werde ich mich auf Gleichstrom beschränken und einen einfachen Spannungsteiler simulieren. Das reicht um die grundsätzlichen Schritte der Simulation einer Schaltung zur erklären.

Zuerst muss ein neuer Schaltplan erstellt werden dafür klickt man entweder im Menü auf „File -> New Schematic“ oder direkt auf dieses Symbol SWCadTutBilder1.png

Danach haben wir einen leeren Schaltplan vor uns den wir nun mit unseren Bauteilen füllen müssen.

Für einen Spannungsteiler brauchen wir zuerst natürlich 2 Widerstände. Um diese in den Schaltplan einzufügen, klicken wir auf das Symbol für einen Widerstand SWCadTutBilder2.png (Achtung! SWCad verwendet standardmäßig das US-Symbol für Widerstände, die gezackte Linie! ) und ordnen 2 Widerstände übereinander im Schaltplan an, indem wir 2 mal nacheinander an die entsprechende Stelle im Schaltplan klicken.

( Anm: Das wie bei uns in Europa übliche, Rechteck Resistor.png für Widerstände ist über "Umwege" auch erreichbar: Component / Misc / EuropeanResistor )


Der Schaltplan sieht nun ungefähr so aus


SWCadTutBilder3.png


Jetzt fehlt natürlich noch die Spannungsquelle und (ganz wichtig) die GND-Symbole. Bei jeder Spicesimulation muss min. 1 GND-Symbol angeschlossen werden.

Zum Einfügen der Spannungsquelle klickt man auf das „Components“-Symbol SWCadTutBilder4.png und wählt das Bauteil „Voltage“ aus. Zum setzen der GND-Symbole klickt man auf SWCadTutBilder5.png.

Die genannten Bauteile werden in der Schaltung platziert. Danach sollte der Schaltplan ungefähr so aussehen.


SWCadTutBilder6.png


Mit den „Move“ bzw. „Drag“ Werkzeugen können die Bauteile verschoben werden. In einem der beiden Modi lassen sich die Bauteile auch drehen und spiegeln indem man auf eines dieser Symbole klickt SWCadTutBilder7.png

Nachdem nun die Bauteile platziert sind müssen sie noch „verkabelt“ werden, das geschieht in dem man das „Wire“-Symbol SWCadTutBilder8.png anklickt und die Anschlusspunkte (markiert durch kleine Rechtecke) der Bauteile entsprechend miteinander verbindet. Die fertige Schaltung sollte dann ungefähr so aussehen.


SWCadTutBilder9.png


Das war es jetzt auch schon fast. Was aber noch fehlt sind die Werte der verschiedenen Bauteile. Diese lassen sich einfach eingeben indem man mit der rechten Maustaste auf das Bauteil klickt, für welches man den Wert eingeben will. Für die Widerstände erscheint folgendes Menü:


SWCadTutBilder10.png


Der Einfachheit halber habe ich für beide Widerstände 100k Ohm eingegeben. Das Menü der Spannungsquelle sieht folgendermaßen aus


SWCadTutBilder11.png


Ich habe 12V für die Spannung gewählt und einen Innenwiderstand von 0.01 Ohm eingegeben. Die Werte erscheinen direkt nach der Eingabe bei dem Entsprechenden Symbol.


SWCadTutBilder12.png


Damit ist die Eingabe des Schaltplans abgeschlossen und die Schaltung kann simuliert werden.

Simulation der eingegebenen Schaltung

Die Simulation der Schaltung ist eigentlich ganz einfach. Zuerst klickt man auf das Symbol „Run“ SWCadTutBilder13.png . Danach erscheint das Menü in dem angeben kann welche Art von Simulation man durchführen möchte.


SWCadTutBilder14.png


Hier wählen wir zuerst den Simulationsmodus „Transient“ und geben in dessen Parametern eine Stop Time von 1s, und eine Start Time von 0 ein. Das bedeutet das der Verlauf der Spannungen und Ströme vom Einschalten an über einen Zeitraum von 1s simuliert werden. Danach bestätigen wir mit „OK“. Im Anschluss erscheint folgendes Fenster


SWCadTutBilder15.png


Hier kann man auswählen welches Diagramm zuerst dargestellt werden soll. Der Einfachheit halber wählen wir hier „V(n001)“ aus. Zur Erklärung: Spice teilt den Schaltplan in Knoten auf (Nodes) V(n001) ist dann die Spannung am Knoten 001, I(R1) ist der Strom durch den Widerstand R1, usw.

Nach dem Bestätigen mit „OK“ läuft die Simulation und das erste Diagramm wird dargestellt.


SWCadTutBilder16.png


Dargestellt wird die Spannung am Knoten V(n001), der Versorgungsspannung an V1 (12V).

Jetzt kommt der spannende Teil der Simulation, das hinzufügen von weiteren Plots. Wenn man mit der Maus in den unten noch sichtbaren Schaltplan fährt, ändert sich der Mauszeiger, entweder in eine Prüfspitze oder eine Strommesszange wenn man über Leitungen bzw. Bauteile fährt.

Wir wollen jetzt die Spannung an R2 in das Diagramm einfügen, dazu fahren wir in der Schaltung mit der Maus auf die Leitung, welche R1 und R2 verbindet. Wenn sich der Mauszeiger in die Prüfspitze verwandelt hat, klickt man darauf und der Plot der Spannung wird in das Diagramm eingefügt.


SWCadTutBilder17.png


Als nächstes interessiert uns der Strom der durch die Widerstände fließt. Dazu geht man genauso vor wie bei den Spannung. Der Unterschied ist nur, daß man nicht auf die Leitung fährt sondern auf das Bauteil, und der Mauszeiger sich in eine Strommesszange verwandelt. Da der Strom in einem Stromkreis (Masche) immer gleich ist, ist es in diesem Fall egal ob man den Strom durch R1 oder R2 wählt. Danach erscheint ein weitere Linie im oben dargestellten Diagramm.


SWCadTutBilder18.png


Interessant ist das eine weitere Skala im Diagramm dazu gekommen ist. Nämlich auf der rechten Seite die Skala für die Stromstärke. Das geschieht automatisch.

Jetzt haben wir alle Diagramme für Spannung und Stromstärke. Aber damit geben wir uns nicht zufrieden. Uns interessiert besonders die Verlustleistung des Spannungsteilers, also wie viel Watt unsere Schaltung und die einzelnen Widerstände verbrauchen.

Die Leistung berechnet sich zu P = U * I, also Leistung = Spannung * Strom.

Zuerst erstellen wir der Übersicht wegen ein neues Diagramm. Dazu klickt man im Simulationsfenster mit der rechten Maustaste, und dann auf „add Plot Plane“. Danach erhält man ein neues Diagramm im Simulationsfenster. Das „alte“ bleibt dabei erhalten. Zuerst lassen wir uns den gesamten Leistungsverbrauch der Schaltung aufzeichnen. Diese berechnet sich zu Versorgungsspannung * Gesamtstromstärke, in unserem Fall also V(n001) * I(R1). Um uns diese Kurve plotten zu lassen klicken wir mit rechts auf das neue noch leere Diagramm, und dann auf „add Trace“. Folgendes Fenster erscheint:


SWCadTutBilder19.png


Ich habe die Zeile auf die es ankommt hervorgehoben. In diese Zeile kann man nämlich eine mathematische Beziehung zwischen den oben wählbaren Strömen/Knoten eingeben. Für die Gesamtleistung der Schaltung, gibt man die oben genannte Formel ( V(n001 * I(R1) ) ein. Nach einem Klick auf Ok wird die Gesamtleistung der Schaltung im vorher leeren Diagramm eingetragen. Die Skala des Diagramms wird automatisch auf Watt eingestellt.


SWCadTutBilder20.png


Diagramme sind leider nicht absolut genau abzulesen, deswegen gibt es die Möglichkeit den Namen des entsprechenden Diagramms anzuklicken (oberhalb des Plots). Dadurch erscheint ein Fenster mit diversen Angaben zum Plott, unter anderem erfährt man dort, dass die gesamte Leistungsaufnahme der Schaltung 720uW beträgt.

Genauso verfährt man wenn man die Leistungsaufnahme eines Widerstandes plotten will. Allerdings ist die Formel der Verlustleistung eines Widerstands P = Spannungsabfall * Stromstärke. Die einzutragende Formel ist also (für R1)

(Versorgungsspannung – Spannung zwischen R1 und R2) * Strom durch R1.

Mit den Worten von LTSpice wäre das dann (V(n001)-V(n002)) * I(R1). Gibt man das genauso wie beim ersten Plot ein, erhält man folgendes Bild


SWCadTutBilder21.png


Durch anklicken der Plottbezeichnung (oben) erfährt man, dass ein Widerstand eine Verlustleistung von 360uW verbraucht. Die Verlustleistung der beiden Widerstände ist natürlich gleich, da sie beide gleich groß sind. Ich habe das mit Absicht so gemacht, jetzt ist es nämlich eure Aufgabe mit den Werten der Widerstände und der Spannungsquelle zu spielen um ein Gefühl für das Programm zu bekommen ;-)

Dazu braucht man nicht noch mal alles neu eingeben sondern kann im unteren Fenster der Schaltung einfach wieder mit rechts auf ein Bauteil klicken und die entsprechenden Werte verändern. Um die Änderung auch in den Diagrammen sichtbar zu machen muss man einfach noch einmal auf SWCadTutBilder13.png klicken und die neuen Werte werden berechnet und sofort dargestellt.


Weitere Hinweise

Zum Speichern der Plot-Einstellungen muss das Fenster mit dem Plot Aktiv sein. Mit "Save Plot Settings" kann man das aktuelle Plot dann speichern. Beim Neustart des Programms sollte die Simulation wieder mit genau den gleichen einstellungen ablaufen.

Zum Exportieren in eine Textdatei klickt man auf „File -> Export“ und gibt dort an, welche Plots wo und wie gespeichert werden sollen. Der WMF-Export funktioniert über „Tools -> Write Plot to .wmf File“ Andere Bauteile werden in gleicher Art und Weise in die Schaltung eingebaut. Das Verfahren ist das gleiche. Um Wechselspannungen zu simulieren klickt man in den Einstellungen der Spannungsquelle (Voltage) auf „Advanced“. So kommt man in ein weiteres Menü in dem man die nötigen Einstellungen vornehmen kann.

Wie geht es weiter?

Mit dem Programm werden schon eine ganze Reihe von Beispielfiles geliefert, die einen ersten Überblick über die Möglichkeiten geben. In der Regel reicht es das File zu laden und die Simulation zu starten. Wenn man einige der Beispiele nicht versteht, ist das normal - einige sind mehr etwas für Elektro-Ingenieure.

Ich habe vor einen 2. Teil des Tutorials zu schreiben in dem es dann um die Simulation von Schaltungen mit Wechselspannung geht. Ich bin noch auf der Suche nach einer geeigneten einfachen Schaltung, die, auch für Anfänger, leicht verständlich ist, aber auch genug Möglichkeiten für interessante Plots bietet. Für Hinweise bin ich immer dankbar ;-)

Codebeispiel

Der Schaltplan des Spannungsteilers im SWCad-Format. Als Datei Spannungsteiler.asc abspeichern.

Version 4 
SHEET 1 880 680 
WIRE -64 368 -64 256 
WIRE -64 176 -64 48 
WIRE -64 48 128 48 
WIRE 128 48 128 80 
WIRE 128 160 128 240 
WIRE 128 320 128 368 
FLAG 128 368 0 
FLAG -64 368 0 
SYMBOL res 112 64 R0 
SYMATTR InstName R1 
SYMATTR Value 100k 
SYMBOL res 112 224 R0 
SYMATTR InstName R2 
SYMATTR Value 100k 
SYMBOL voltage -64 160 R0 
WINDOW 123 0 0 Left 0 
WINDOW 39 24 132 Left 0 
SYMATTR InstName V1 
SYMATTR Value 12V 
SYMATTR SpiceLine Rser=0.01 
TEXT -98 506 Left 0 !.tran 0 1 0

Autoren

  • Sonic
  • Wiki konvertiert Frank
  • Bilder Vish



Weblinks